Back to overview
Degraded
Customers unable to sign contracts
Oct 31 at 12:00pm GMT
Affected services
Customer Journey
Resolved
Oct 31 at 03:30pm GMT
The issue has been identified and resolved allowing customer to sign their contracts when clicking through from their emails.
Affected services
Created
Oct 31 at 12:00pm GMT
We are currently experiencing some issues where customers cannot sign their contracts.
We are investigating the root cause of this issue.
Affected services